EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Octal Fractions

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4968 Accepted: 2670

Description

Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.953125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point. 

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals.

Input

The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k.

Output

Your output will consist of a sequence of lines of the form 

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]


where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

Sample Input

0.75
0.0001
0.01234567

Sample Output

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]

Source


 
高精度
import java.io.*;
import java.math.*;
import java.util.*;
import java.text.*;
 
public class Main
 {
    public static void main(String[] args) 
    {
        Scanner cin = new Scanner(System.in);
        BigDecimal ans, t, tmp;
        while(cin.hasNext())
        {
            String st = cin.nextLine();          //  字符串读入。
            t = BigDecimal.valueOf(1);
            ans = BigDecimal.valueOf(0);
            int i, sta = st.indexOf('.');        //  sta = 2是一样的,这样保险点,预防前缀0。
            for(i = sta + 1; i < st.length(); i ++)
            {
                tmp = BigDecimal.valueOf(st.charAt(i) - '0');
                t = t.divide(new BigDecimal("8"));
                tmp = tmp.multiply(t);
                //System.out.println(t);
                ans = ans.add(tmp);
            }
            System.out.println(st+" [8] = "+ans+" [10]");
        }
        System.exit(0);
    }
}
posted on 2011-06-09 15:30  Eric-Yang  阅读(269)  评论(0编辑  收藏  举报