EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Primary Arithmetic

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7852 Accepted: 2962

Description

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output

For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

Sample Input

123 456
555 555
123 594
0 0

Sample Output

No carry operation.
3 carry operations.
1 carry operation.

Source


 
模拟加法进位
#include <cstdio>
#include <cstring>

using namespace std;

int num1[15], num2[15];
char ch[15],ch1[15];
int num1_len, num2_len, max_len;
int sum;

int main()
{
    while(scanf("%s%s",ch,ch1)!=EOF)
    {
        if(!strcmp(ch,"0") && !strcmp(ch1,"0"))
            break;
        sum=0;
        memset(num1,0,sizeof(num1));
        memset(num2,0,sizeof(num2));
        num1_len=strlen(ch);
        num2_len=strlen(ch1);
        for(int i=0; i<num1_len; i++)
            num1[i]=ch[num1_len-i-1]-'0';
        for(int i=0; i<num2_len; i++)
            num2[i]=ch1[num2_len-i-1]-'0';
        max_len=num1_len>num2_len?num1_len:num2_len;
        for(int i=0; i<max_len; i++)
        {
            if(num1[i]+num2[i]>=10)
            {
                num1[i+1]+=(num1[i]+num2[i])/10;
                sum++;
            }
        }
        if(sum==1)
            printf("%d carry operation.\n",sum);
        else if(sum>1)
            printf("%d carry operations.\n",sum);
        else
            printf("No carry operation.\n");
    }
    return 0;
}
posted on 2011-06-02 17:28  Eric-Yang  阅读(274)  评论(0编辑  收藏  举报