EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Stamps

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6687 Accepted: 3105

Description

Background 
Everybody hates Raymond. He's the largest stamp collector on planet earth and because of that he always makes fun of all the others at the stamp collector parties. Fortunately everybody loves Lucy, and she has a plan. She secretly asks her friends whether they could lend her some stamps, so that she can embarrass Raymond by showing an even larger collection than his. 
Problem 
Raymond is so sure about his superiority that he always tells how many stamps he'll show. And since Lucy knows how many she owns, she knows how many more she needs. She also knows how many friends would lend her some stamps and how many each would lend. But she'd like to borrow from as few friends as possible and if she needs too many then she'd rather not do it at all. Can you tell her the minimum number of friends she needs to borrow from?

Input

The first line contains the number of scenarios. Each scenario describes one collectors party and its first line tells you how many stamps (from 1 to 1000000) Lucy needs to borrow and how many friends (from 1 to 1000) offer her some stamps. In a second line you’ll get the number of stamps (from 1 to 10000) each of her friends is offering.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line with the minimum number of friends Lucy needs to borrow stamps from. If it’s impossible even if she borrows everything from everybody, write impossible. Terminate the output for the scenario with a blank line.

Sample Input

3
100 6
13 17 42 9 23 57
99 6
13 17 42 9 23 57
1000 3
314 159 265

Sample Output

Scenario #1:
3

Scenario #2:
2

Scenario #3:
impossible

Source

TUD Programming Contest 2005, Darmstadt, Germany

 
水过
#include <iostream>
#include <algorithm>

using namespace std;

bool cmp(int i, int j)
{
    return i>j;
}

int main()
{
    int cas;
    int need, fri;
    int lend[1000];
    int sum;

    cin>>cas;
    for(int cas_no=1; cas_no<=cas; cas_no++)
    {
        cout<<"Scenario #"<<cas_no<<":"<<endl;
        cin>>need>>fri;
        sum=0;
        for(int i=0; i<fri; i++)
        {
            cin>>lend[i];
            sum+=lend[i];
        }
        if(sum<need)
           cout<<"impossible"<<endl;
        else
        {
           sort(lend,lend+fri,cmp);
           sum=0;
           for(int i=0; i<fri; i++)
           {
               sum+=lend[i];
               if(sum>=need)
                {
                    cout<<i+1<<endl;
                    break;
                }
           }
        }
        cout<<endl;
    }
    return 0;
}
posted on 2011-06-02 14:09  Eric-Yang  阅读(285)  评论(0编辑  收藏  举报