EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

The Triangle

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24947 Accepted: 14498

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source


 
DP:同poj3176
#include <iostream>
#include <cstring>

using namespace std;

const int N=100;
int map[N+1][N+1];
int dp[N+1][N+1];

int main()
{
    int n;
    int rlt;

    while(cin>>n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=i; j++)
            {
                cin>>map[i][j];
            }
        }
        //DP
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=i; j++)
            {
                if(dp[i-1][j]>dp[i-1][j-1])
                {
                    dp[i][j]=map[i][j]+dp[i-1][j];
                }
                else
                {
                    dp[i][j]=map[i][j]+dp[i-1][j-1];
                }
            }
        }
        rlt=dp[n][1];
        for(int i=2; i<=n; i++)
        {
            if(rlt<dp[n][i])
                rlt=dp[n][i];
        }
        cout<<rlt<<endl;
    }

    return 0;
}
posted on 2011-05-25 16:59  Eric-Yang  阅读(239)  评论(0编辑  收藏  举报