EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18511 Accepted: 7963

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

 
DP: LIS, poj1836是他的升级版
#include <iostream>
#include <cstring>

using namespace std;

const int Size=1000;
int dp[Size+1];
int sq[Size+1];

int main()
{
    int n;
    int rlt;

    while(cin>>n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            cin>>sq[i];
        }
        //dp
        for(int i=1; i<=n; i++)
        {
            dp[i]=1;
            for(int j=1; j<=i-1; j++)
            {
                if(sq[j]<sq[i])
                {
                    if(dp[i]<dp[j]+1)
                    {
                        dp[i]=dp[j]+1;
                    }
                }
            }
        }
        rlt=0;
        for(int i=1; i<=n; i++)
        {
             if(rlt<dp[i])
                 rlt=dp[i];
        }
        cout<<rlt<<endl;
    }
    return 0;
}
posted on 2011-05-25 16:14  Eric-Yang  阅读(270)  评论(0编辑  收藏  举报