EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Pearls

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4381 Accepted: 2101

Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. 
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. 
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the 
prices remain the same. 
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. 
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. 

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one. 

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). 
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. 

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list. 

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344

Source


 

首先,我们要注意到一点,如果某个等级i的珠宝用比它等级高的珠宝j代替会产生最优解,那么处于等级[i+1,j-1]区间内的珠宝也必须用珠宝j代替

证明如下:

假设区间[i+1,j-1]内存在等级k的珠宝不用等级为j的珠宝代替,因为必定会买等级j的珠宝,那么它的可选范围就是[k,j-1]

如果它选择就买等级x的,那么等级i的珠宝用等级x的代替就可以,因为等级越高,价格越高,这样的代价必定更小,于是产生了矛盾

于是对于等级i,只要枚举它前面连续几个等级的珠宝选择用它代替即好

dp[i]=min(dp[i],dp[j]+(sum(j+1...i))+10)*p[i])

#include <iostream>
#include <cstring>

using namespace std;

const int SIZE=100;
int p[SIZE+1], a[SIZE+1];
int sum[SIZE+1], dp[SIZE+1];


int main()
{
    int cas;
    int c;

    cin>>cas;
    while(cas--)
    {
        cin>>c;
        memset(sum,0,sizeof(sum));
        for(int i=1; i<=c; i++)
        {
            cin>>a[i]>>p[i];
            sum[i]=sum[i-1]+a[i];
            dp[i]=(sum[i]+10)*p[i];
        }
        //dp
        for(int i=1; i<=c; i++)
        {
            for(int j=1; j<=i-1; j++)
            {
                if(dp[i]>(sum[i]-sum[j]+10)*p[i]+dp[j])
                {
                    dp[i]=(sum[i]-sum[j]+10)*p[i]+dp[j];
                }
            }
        }
        cout<<dp[c]<<endl;

    }
    return 0;
}
posted on 2011-05-25 15:50  Eric-Yang  阅读(275)  评论(0编辑  收藏  举报