EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Network Saboteur

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5766 Accepted: 2449

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source

Northeastern Europe 2002, Far-Eastern Subregion

 
DFS: 没剪枝,也过了。。。
#include <iostream>
#include <cstring>

using namespace std;

const int SIZE=20;
const bool A=0;
const bool B=1;

int C[SIZE][SIZE];
bool join[SIZE];
int maxV;
int n;

void DFS(int depth, int sum)
{
    if(depth>=n)
    {
        if(sum>maxV)
            maxV=sum;
        return;
    }

    int m;

    for(int set=0; set<=1; set++)
    {
        m=0;
        join[depth]=set;
        for(int i=0; i<depth; i++)
        {
            if(join[i]!=join[depth])
            {
                m+=C[depth][i];
            }
        }
        DFS(depth+1,sum+m);
    }
}
int main()
{
    while(cin>>n)
    {
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                cin>>C[i][j];
            }
        }
        maxV=-1;
        DFS(0,0);
        cout<<maxV<<endl;
    }
    return 0;
}
posted on 2011-05-13 14:42  Eric-Yang  阅读(213)  评论(0编辑  收藏  举报