EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

A Knight's Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14310 Accepted: 4766

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

 
DFS
#include <iostream>
#include <cstring>

using namespace std;

typedef struct
{
    int p;
    int q;
}Node;

bool map[27][27];
Node record[900];
int p,q;
bool isOK;
const int xx[8]={-1, 1, -2, 2, -2, 2, -1, 1};
const int yy[8]={-2, -2, -1, -1, 1, 1, 2, 2};

bool check(Node temp)
{
    return temp.p<=p && temp.q<=q && temp.p>=1 && temp.q>=1 && !map[temp.p][temp.q];
}

void DFS(int x, int y, int step)
{
    Node temp;

    if(step==p*q+1)
    {
        isOK=true;
        for(int i=1; i<=p*q; i++)
        {
            cout<<char(record[i].q+'A'-1)<<record[i].p;
        }
        return ;
    }
    if(!isOK)
    {
        for(int i=0; i<8; i++)
        {
           temp.p=x+xx[i];
           temp.q=y+yy[i];
           if(check(temp))
           {
               map[temp.p][temp.q]=true;
               record[step].p=temp.p;
               record[step].q=temp.q;
               //cout<<step<<endl;
               DFS(temp.p,temp.q,step+1);
               map[temp.p][temp.q]=false;
           }
        }
    }
}
int main()
{
    int case_no;
    int step;

    cin>>case_no;
    for(int cas=1; cas<=case_no; cas++)
    {
        cout<<"Scenario #"<<cas<<":"<<endl;
        memset(map,false,sizeof(map));
        cin>>p>>q;
        step=1;

        isOK=false;
        map[1][1]=true;
        record[step].p=1;
        record[step].q=1;

        DFS(1,1,step+1);

        if(!isOK)
            cout<<"impossible";
        cout<<endl<<endl;
    }
    return 0;
}
posted on 2011-05-04 19:54  Eric-Yang  阅读(234)  评论(0编辑  收藏  举报