EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

A Bug's Life

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 16957 Accepted: 5446

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

 
POJ 1703 两个帮派的简化版。少加了\n, PE了一次,囧~
#include <iostream>
#include <cstdio>

using namespace std;

const int N=2000;
int parent[N+1];
int relation[N+1];    //0:和根节点同类, 1:不同类

void createSet(int x)
{
    parent[x]=x;
    relation[x]=0;
}

int find(int x)
{
    int temp;

    if(x!=parent[x])
    {
        temp=parent[x];
        parent[x]=find(parent[x]);
        relation[x]=(relation[x]-relation[temp]+2)%2;
    }
    return parent[x];
}

void unionSet(int x, int y)
{
    int pa,pb;

    pa=find(x);
    pb=find(y);

    parent[pb]=pa;
    relation[pb]=(relation[y]-relation[x]+1+2)%2;
}

int main()
{
    int t,cas_no;
    int n,m;
    int a,b;
    int pa, pb;
    bool hasHomo;

    scanf("%d",&t);
    cas_no=1;
    while(cas_no<=t)
    {
        hasHomo=false;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            createSet(i);
        }
        while(m--)
        {
            scanf("%d%d",&a,&b);
            pa=find(a);
            pb=find(b);
            if(pa!=pb)
               unionSet(a,b);
            else
            {
                if(relation[a]==relation[b])
                   hasHomo=true;
            }
        }
        printf("Scenario #%d:\n",cas_no);
        if(hasHomo)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
        printf("\n");
        cas_no++;
    }
    return 0;
}
  
posted on 2011-04-29 11:22  Eric-Yang  阅读(396)  评论(0编辑  收藏  举报