EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Navigation Nightmare

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 2033 Accepted: 848
Case Time Limit: 1000MS

Description

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n): 
           F1 --- (13) ---- F6 --- (9) ----- F3

| |
(3) |
| (7)
F4 --- (20) -------- F2 |
| |
(2) F5
|
F7

Being an ASCII diagram, it is not precisely to scale, of course. 

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path 
(sequence of roads) links every pair of farms. 

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road: 

There is a road of length 10 running north from Farm #23 to Farm #17 
There is a road of length 7 running east from Farm #1 to Farm #17 
... 

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob: 

What is the Manhattan distance between farms #1 and #23? 

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. 
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points). 

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1". 

Input

* Line 1: Two space-separated integers: N and M


* Lines 2..M+1: Each line contains four space-separated entities, F1,
F2, L, and D that describe a road. F1 and F2 are numbers of
two farms connected by a road, L is its length, and D is a
character that is either 'N', 'E', 'S', or 'W' giving the
direction of the road from F1 to F2.

* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's
queries

* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob
and contains three space-separated integers: F1, F2, and I. F1
and F2 are numbers of the two farms in the query and I is the
index (1 <= I <= M) in the data after which Bob asks the
query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

queries. Each line should contain either a distance
measurement or -1, if it is impossible to determine the
appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13. 
At time 3, the distance between 1 and 4 is still unknown. 
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10. 

Source


 

解题思路: 并查集,在find和union间加入相对于根位置的关系。我的做法定义了记录相对于根为坐标系原点的坐标系的相对坐标的数组cx,cy。具体关系很好推。

在discuss中,找到了我犯的两个错误,及其解决方法

1.Stack Overflow的用C++提交,不要用G++,栈太小了

2.因为我是先将所有建树和询问的信息全部读入,然后边建树变判断是否符合index的时间,也就是我只判断了单组的询问,如果几组询问的index是相同的,就会只输出一组答案。

5 4
1 3 5 E
1 2 5 S
1 5 5 W
1 4 5 N
3
2 5 4
2 4 4
3 4 4


答案是
10
10
10


#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

typedef struct
{
    int f1;
    int f2;
    int l;
    char d;
}Record;

typedef struct
{
    int f1;
    int f2;
    int i;
}Query;

Record rec[40001];
Query que[10001];
int parent[40001];
int cx[40001];
int cy[40001];

void createSet(int x)
{
    parent[x]=x;
    cx[x]=0;
    cy[x]=0;
}

int find(int x)
{
    int temp;

    if(x!=parent[x])
    {
        temp=parent[x];
        parent[x]=find(parent[x]);
        cx[x]=cx[temp]+cx[x];
        cy[x]=cy[temp]+cy[x];
    }
    return parent[x];
}

void unionSet(int i)
{
    int a,b;
    int pa,pb;

    a=rec[i].f1;
    b=rec[i].f2;
    pa=find(a);
    pb=find(b);
    parent[pb]=pa;

    cx[pb]=cx[a]-cx[b];
    cy[pb]=cy[a]-cy[b];
    switch(rec[i].d)
    {
        case 'E':
            cx[pb]+=rec[i].l;
            break;
        case 'W':
            cx[pb]-=rec[i].l;
            break;
        case 'S':
            cy[pb]-=rec[i].l;
            break;
        case 'N':
            cy[pb]+=rec[i].l;
            break;
    }
}

int main()
{
    int n,m,k;
    int pf1,pf2;
    int rec_i, ans_i;
    int lx,ly;

    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d %d %c\n",&rec[i].f1,&rec[i].f2,&rec[i].l,&rec[i].d);
        }
        scanf("%d",&k);
        for(int i=1; i<=k; i++)
        {
            scanf("%d%d%d",&que[i].f1,&que[i].f2,&que[i].i);
        }

        for(int i=1; i<=n; i++)   //create set
        {
            createSet(i);
        }
        rec_i=1;
        ans_i=1;
        while(rec_i<=m)
        {
            pf1=find(rec[rec_i].f1);
            pf2=find(rec[rec_i].f2);
            if(pf1!=pf2)
                unionSet(rec_i);

            while(que[ans_i].i==rec_i)
            {
                pf1=find(que[ans_i].f1);
                pf2=find(que[ans_i].f2);
                if(pf1!=pf2)
                    printf("-1\n");
                else
                {
                    lx=(int)abs(cx[que[ans_i].f1]-cx[que[ans_i].f2]);
                    ly=(int)abs(cy[que[ans_i].f1]-cy[que[ans_i].f2]);
                    printf("%d\n", lx+ly);
                }
                ans_i++;
            }
            rec_i++;
        }
    }
    return 0;
}
posted on 2011-04-28 15:55  Eric-Yang  阅读(460)  评论(0编辑  收藏  举报