EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16443 Accepted: 4809

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


解题思路:  和POJ1182思路差不多,不过比1182简单许多。在并查集加了关系。

                   在union的时候,不使用启发式优化,在1182中看到,起优化效果不是很明显,而且这样可以简化关系的逻辑关系。

                   由于union时候只是更新了父节点之间的relation,在find的时候对(原父节点)之下的节点关系进行更新。

                   2维的关系很好推,只是做题的时候把10^5当成10000了,RE了2次(下次注意点)!!!!

#include <iostream>
#include <cstdio>

using namespace std;

int parent[100010];
int relation[100010];    //0:和根节点同类, 1:不同类

void createSet(int x)
{
    parent[x]=x;
    relation[x]=0;
}

int find(int x)
{
    int temp;

    if(x!=parent[x])
    {
        temp=parent[x];
        parent[x]=find(parent[x]);
        relation[x]=(relation[x]-relation[temp]+2)%2;
    }
    return parent[x];
}

void unionSet(int x, int y)
{
    int pa,pb;

    pa=find(x);
    pb=find(y);

    parent[pb]=pa;
    relation[pb]=(relation[y]-relation[x]+1+2)%2;
}

int main()
{
    int t;
    int n,m;
    int a,b;
    char command;
    int pa, pb;

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            createSet(i);
        }
        while(m--)
        {
            getchar();
            scanf("%c%d%d",&command,&a,&b);
            if(command=='D')
            {
                pa=find(a);
                pb=find(b);
                if(pa!=pb)
                    unionSet(a,b);
            }
            if(command=='A')
            {
                if(find(a)==find(b))
                {
                    if(relation[a]==relation[b])
                    {
                        printf("In the same gang.\n");
                    }
                    else
                    {
                        printf("In different gangs.\n");
                    }
                }
                else
                {
                    printf("Not sure yet.\n");
                }
            }
        }
    }
    return 0;
}
posted on 2011-04-28 12:03  Eric-Yang  阅读(254)  评论(0编辑  收藏  举报