EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::



Snowflake Snow Snowflakes

Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 17556 Accepted: 4509

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

哈希: 所有雪花6arms求和和mod大prime。

#include <iostream>
#include <cstdio>
#include <vector>

using namespace std;

const int prime=14997;
int sf[100000][6];
vector<int> has[15000];

bool compare(int a, int b)
{
    bool flag=false;

    int i,j;
    for(i=0; i<6; i++)
    {
        if(sf[a][0]==sf[b][i])
        {
            //clock
            for(j=1; j<6; j++)
            {
                if(sf[a][j]!=sf[b][(i+j)%6])
                    break;
            }
            if(j==6)
                flag=true;
            //counter clock
            for(j=1; j<6; j++)
            {
                if(sf[a][6-j] != sf[b][(i+j)%6])
                    break;
            }
            if(j==6)
                flag=true;
        }
    }
    return flag;
}

bool check()
{
    for(int i=0; i<15000; i++)
    {
        for(int j=0; j<has[i].size(); j++)
        {
            for(int k=j+1; k<has[i].size(); k++)
            {
                if(compare(has[i][j],has[i][k]))
                    return true;
            }
        }
    }
    return false;
}

int main()
{
    int n;
    int hascode, sum;
    bool isSame;

    scanf("%d",&n);
    for(int i=0; i<=n-1; i++)
    {
        sum=0;
        for(int j=0; j<=5; j++)
        {
            scanf("%d",&sf[i][j]);
            sum+=sf[i][j];
        }
        hascode=sum%prime;
        has[hascode].push_back(i);
    }


    isSame=check();

    if(isSame)
        printf("Twin snowflakes found.\n");
    else
        printf("No two snowflakes are alike.\n");
    return 0;
}

posted on 2011-04-18 18:31  Eric-Yang  阅读(313)  评论(0编辑  收藏  举报