EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Asteroids

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 6748
Accepted: 3530

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.

 

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

 

解题思路:

求最小的边覆盖所有点,讲边和点对换所得的图G‘中,即求G’的点最小覆盖。

G中edge[r,c]=G'的点r,c。可看为二分图。

在二分图中,最小覆盖集=最大匹配数

匈牙利算法简单解决。

 

#include<iostream>
#include<cstring>

using namespace std;

bool visit[501];
bool map[501][501];
int result[501];
int N;

bool find(int startNodes)
{
    for(int i=1; i<=N; i++)
    {
        if(map[startNodes][i] && !visit[i]) //startNode unvisited neighbor nodes
        {
            visit[i]=true;//try to in augment path
            if(result[i]==0 || find(result[i])) //i is not in matched graph || has a augment path
            {
                result[i]=startNodes;  //matched
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int K;
    int r,c;
    int edge;

    memset(map,0,sizeof(map));
    memset(result,0,sizeof(result));
    edge=0;

    cin>>N>>K;
    for(int i=1; i<=K; i++)
    {
        cin>>r>>c;
        map[r][c]=true;
    }

    for(int i=1; i<=N; i++)
    {
        memset(visit,0,sizeof(visit));
        if(find(i))
           edge++;
    }

    cout<<edge<<endl;
    return 0;
}

posted on 2011-01-05 17:38  Eric-Yang  阅读(241)  评论(0编辑  收藏  举报