EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::
Wormholes
Time Limit: 2000MS
Memory Limit: 65536K
tal Submissions: 11389
Accepted: 3998

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

bellman-ford

#include <iostream>
#include <cstring>
#include <cstdio>



using namespace std;


typedef struct
{
    int s,e;
    int t;
}edge;

edge biway[5001];
edge oneway[201];
int  d[501];
int F;


int main()

{

    int N,M,W;
    int s,e,t;

    scanf("%d",&F);
    for(int f=1; f<=F; f++)
    {
        memset(biway,0,sizeof(biway));
        memset(oneway,0,sizeof(oneway));
        memset(d,10000,sizeof(d));

        scanf("%d%d%d",&N,&M,&W);
        for(int i=1; i<=M; i++)
        {
            scanf("%d%d%d",&s,&e,&t);
            biway[i].s=s;
            biway[i].e=e;
            biway[i].t=t;
            biway[i+2500].s=e;
            biway[i+2500].e=s;
            biway[i+2500].t=t;
        }
        for(int i=1; i<=W; i++)
        {
            scanf("%d%d%d",&s,&e,&t);
            oneway[i].s=s;
            oneway[i].e=e;
            oneway[i].t=-t;
        }

        //bellman-ford
        for(int i=0; i<N; i++)
        {
            for(int j=1; j<=M; j++)
            {
                //relax
                if( d[biway[j].e] > d[biway[j].s] + biway[j].t)
                    d[biway[j].e] = d[biway[j].s] + biway[j].t;

                if( d[biway[j+2500].e] > d[biway[j+2500].s] + biway[j+2500].t)
                    d[biway[j+2500].e] = d[biway[j+2500].s] + biway[j+2500].t;
            }

            for(int j=1; j<=W; j++)
            {
                if(d[oneway[j].e] > d[oneway[j].s]+oneway[j].t)
                    d[oneway[j].e]=d[oneway[j].s]+oneway[j].t;
            }
        }

        int isRelax=0;
        for(int j=1; j<=M; j++)
        {
            //relax
            if( d[biway[j].e] > d[biway[j].s] + biway[j].t)
               isRelax=1;

            if( d[biway[j+2500].e] > d[biway[j+2500].s] + biway[j+2500].t)
                isRelax=1;
        }

        for(int j=1; j<=W; j++)
        {
            if(d[oneway[j].e] > d[oneway[j].s]+oneway[j].t)
                isRelax=1;
        }

        if(isRelax)
            printf("YES\n");
        else
            printf("NO\n");
    }


    return 0;

}


posted on 2010-12-31 11:21  Eric-Yang  阅读(170)  评论(0编辑  收藏  举报