HDU 1856 More is better,并查集应用

http://acm.hdu.edu.cn/showproblem.php?pid=1856

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 12984    Accepted Submission(s): 4756


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

 

Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

 

Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
分析:并查集简单应用,最后输出的是最大的等价类中元素的个数。但是数据量比较大,要注意进行路径压缩,否则可能会TLE。
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 10000000;
int F[maxn], num[maxn];
int Find(int x)
{
    if(F[x] == -1) return x;
    return Find(F[x]);
}
void Union(int x, int y)
{
    int t1 = Find(x);
    int t2 = Find(y);
    if(t1 != t2)
    {
        if(num[t2] > num[t1])
        {
            F[t1] = t2;
            num[t2] += num[t1];
        }
        else
        {
            F[t2] = t1;
            num[t1] += num[t2];
        }
    }
}
int main()
{
    int n, a, b;
    while(~scanf("%d", &n))
    {
        int maxx = 0;
        for(int i = 1; i <= maxn; i++)
            num[i] = 1;
        memset(F, -1, sizeof(F));
        while(n--)
        {
            scanf("%d%d", &a, &b);
            if(maxx < a)
                maxx = a;
            if(maxx < b)
                maxx = b;
            Union(a, b);
        }
        int cnt = 1;
        for(int i = 1; i <= maxx; i++)
            if(cnt < num[i])
                cnt = num[i];
        printf("%d\n", cnt);
    }
    return 0;
}
View Code

 

posted @ 2014-04-23 00:15  Sign_  阅读(385)  评论(0编辑  收藏  举报