Castle

K. has stumbled upon a weird game while playing on his computer. The game consists of an initial
string S of length N (1 ≤ N ≤ 1000) and an empty set T. The following events might occur during
the game:
• a character is added at the end of S, thus increasing its length by 1
• the string S is added to the set T
• the game master inquires: “How many strings in T are suffixes of S?”. A suffix of S is a substring
which can start at any position in S, but must finish on the last position of S.
Because K. wants to Go visit a famous castle near his hometown, you must help him deal with the
game as quickly as possible.
Input
The input file contains several test cases, each of them as described below.
The first line of the input contains two integers: N, the length of the initial string S and E, the
number of events (E ≤ 1200000).
The second line describes the string S; the string consists only of lowercase Roman alphabet (a..z).
The following E lines describe the events. Each of these lines contains an integer p, describing the
event type.
• If p is 1, then it is followed by a character (a-z), which will be added at the end of S.
• If p is 2, then the string S is added in T.
• If p is 3, then you must respond to the query “How many strings in T are suffixes of the current
S?”
Output
For each test case, the output must follow the description below.
The output should consist of a line containing an integer for each type 3 event in the input, which
represents the answer to the query. Note: T is a set, so it doesn’t contain duplicates.
Explanation for the sample:
Initially S is ‘a’.
After the first event T becomes {a}.
After the second and third event S becomes ‘aba’.
After the fourth event T becomes {a, aba}.
After the fifth event T becomes {a, aba}.
After the sixth and seventh event S becomes ‘abaca’.
The result of the query is 1 (‘a’).
After the ninth and tenth event S becomes ‘abacaba’.
The result of the query is 2 (‘a’ and ‘aba’).
Sample Input
1 11 

a

2

1 b
1 a 

2

2
1 c
1 a 

3
1 b
1 a 

3
Sample Output 

1

2

分析:kmp,充分利用next数组性质,注意转移和判重;

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <bitset>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <cassert>
#include <ctime>
#define rep(i,m,n) for(i=m;i<=(int)n;i++)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define vi vector<int>
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define ll long long
#define pi acos(-1.0)
#define pii pair<int,int>
#define sys system("pause")
#define ls rt<<1
#define rs rt<<1|1
const int maxn=2e6+10;
const int N=5e2+10;
using namespace std;
ll gcd(ll p,ll q){return q==0?p:gcd(q,p%q);}
ll qpow(ll p,ll q){ll f=1;while(q){if(q&1)f=f*p;p=p*p;q>>=1;}return f;}
int n,m,k,t,nxt[maxn],num[maxn],ok[maxn];
char a[maxn];
void init()
{
    nxt[0]=-1;
    int j=-1;
    for(int i=0;i<n;i++)
    {
        while(!(j==-1||a[i]==a[j]))j=nxt[j];
        nxt[i+1]=++j;
    }
}
int main()
{
    int i,j;
    int q;
    scanf("%d%d%s",&n,&q,a);
    init();
    while(q--)
    {
        int op;
        char b[10];
        scanf("%d",&op);
        if(op==1)
        {
            scanf("%s",b);
            a[n++]=b[0];
            int pos=nxt[n-1];
            while(!(pos==-1||a[n-1]==a[pos]))pos=nxt[pos];
            nxt[n]=pos+1;
            num[n]=num[pos+1];
        }
        else if(op==2)
        {
            if(!ok[n])
            {
                ++num[n];
                ok[n]=1;
            }
        }
        else
        {
            printf("%d\n",num[n]);
        }
    }
    return 0;
}
posted @ 2017-07-14 15:42  mxzf0213  阅读(507)  评论(0编辑  收藏  举报