Dominating Patterns

Time Limit:3000MS   Memory Limit:Unknown   64bit IO Format:%lld & %llu

Description

The archaeologists are going to decipher a very mysterious ``language". Now, they know many language patterns; each pattern can be treated as a string on English letters (only lower case). As a sub string, these patterns may appear more than one times in a large text string (also only lower case English letters).

What matters most is that which patterns are the dominating patterns. Dominating pattern is the pattern whose appearing times is not less than other patterns.

It is your job to find the dominating pattern(s) and their appearing times.

Input

The entire input contains multi cases. The first line of each case is an integer, which is the number of patternsN1$ \le$N$ \le$150. Each of the following N lines contains one pattern, whose length is in range [1, 70]. The rest of the case is one line contains a large string as the text to lookup, whose length is up to106.

At the end of the input file, number `0' indicates the end of input file.

Output

For each of the input cases, output the appearing times of the dominating pattern(s). If there are more than one dominating pattern, output them in separate lines; and keep their input order to the output.

Sample Input

 

2 
aba 
bab 
ababababac 
6 
beta 
alpha 
haha 
delta 
dede 
tata 
dedeltalphahahahototatalpha 
0

Sample Output

 

4 
aba 
2 
alpha 
haha
分析:ac自动机;
代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <unordered_map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#define rep(i,m,n) for(i=m;i<=n;i++)
#define rsp(it,s) for(set<int>::iterator it=s.begin();it!=s.end();it++)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define vi vector<int>
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define ll long long
#define pi acos(-1.0)
#define pii pair<int,int>
#define Lson L, mid, ls[rt]
#define Rson mid+1, R, rs[rt]
#define sys system("pause")
#define freopen freopen("in.txt","r",stdin)
const int maxn=1e5+10;
using namespace std;
ll gcd(ll p,ll q){return q==0?p:gcd(q,p%q);}
ll qpow(ll p,ll q){ll f=1;while(q){if(q&1)f=f*p;p=p*p;q>>=1;}return f;}
inline ll read()
{
    ll x=0;int f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int n,m,k,t,ma;
char a[1000010],b[151][80];
struct node
{
    int ch[maxn][26],f[maxn],val[maxn],last[maxn],cnt[maxn],sz;
    void init()
    {
        sz=0;
        memset(ch[0],0,sizeof(ch[0]));
        memset(cnt,0,sizeof(cnt));
    }
    int idx(char x)
    {
        return x-'a';
    }
    void insert(char *p,int v)
    {
        int pos=0;
        for(int i=0;p[i];i++)
        {
            int x=idx(p[i]);
            if(!ch[pos][x])
            {
                ch[pos][x]=++sz;
                memset(ch[sz],0,sizeof(ch[sz]));
                val[sz]=0;
            }
            pos=ch[pos][x];
        }
        val[pos]=v;
    }
    void out(int x)
    {
        if(x)
        {
            cnt[val[x]]++;
            out(last[x]);
        }
    }
    void find(char *p)
    {
        int pos=0;
        for(int i=0;p[i];i++)
        {
            int x=idx(p[i]);
            pos=ch[pos][x];
            if(val[pos])out(pos);
            else if(last[pos])out(last[pos]);
        }
    }
    void fail()
    {
        queue<int>p;
        f[0]=0;
        for(int i=0;i<26;i++)
        {
            int x=ch[0][i];
            if(x)f[x]=0,p.push(x),last[x]=0;
        }
        while(!p.empty())
        {
            int x=p.front();
            p.pop();
            for(int i=0;i<26;i++)
            {
                int y=ch[x][i];
                if(!y)
                {
                    ch[x][i]=ch[f[x]][i];
                    continue;
                }
                p.push(y);
                int v=f[x];
                while(v&&!ch[v][i])v=f[v];
                f[y]=ch[v][i];
                last[y]=val[f[y]]?f[y]:last[f[y]];
            }
        }
    }
}ac;
int main()
{
    int i,j;
    while(~scanf("%d",&n)&&n)
    {
        ac.init();
        rep(i,1,n)
        {
            scanf("%s",b[i]);
            ac.insert(b[i],i);
        }
        ac.fail();
        scanf("%s",a);
        ac.find(a);
        ma=0;
        rep(i,1,n)ma=max(ma,ac.cnt[i]);
        printf("%d\n",ma);
        rep(i,1,n)if(ma==ac.cnt[i])printf("%s\n",b[i]);
    }
    //system("Pause");
    return 0;
}
posted @ 2016-11-17 23:00  mxzf0213  阅读(236)  评论(0编辑  收藏  举报