hdu2829 四边形优化dp

Lawrence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1701    Accepted Submission(s): 737

Problem Description
T. E. Lawrence was a controversial figure during World War I. He was a British officer who served in the Arabian theater and led a group of Arab nationals in guerilla strikes against the Ottoman Empire. His primary targets were the railroads. A highly fictionalized version of his exploits was presented in the blockbuster movie, "Lawrence of Arabia".

You are to write a program to help Lawrence figure out how to best use his limited resources. You have some information from British Intelligence. First, the rail line is completely linear---there are no branches, no spurs. Next, British Intelligence has assigned a Strategic Importance to each depot---an integer from 1 to 100. A depot is of no use on its own, it only has value if it is connected to other depots. The Strategic Value of the entire railroad is calculated by adding up the products of the Strategic Values for every pair of depots that are connected, directly or indirectly, by the rail line. Consider this railroad:  


Its Strategic Value is 4*5 + 4*1 + 4*2 + 5*1 + 5*2 + 1*2 = 49.

Now, suppose that Lawrence only has enough resources for one attack. He cannot attack the depots themselves---they are too well defended. He must attack the rail line between depots, in the middle of the desert. Consider what would happen if Lawrence attacked this rail line right in the middle:  

The Strategic Value of the remaining railroad is 4*5 + 1*2 = 22. But, suppose Lawrence attacks between the 4 and 5 depots:  

The Strategic Value of the remaining railroad is 5*1 + 5*2 + 1*2 = 17. This is Lawrence's best option.

Given a description of a railroad and the number of attacks that Lawrence can perform, figure out the smallest Strategic Value that he can achieve for that railroad.  
 

 

Input
There will be several data sets. Each data set will begin with a line with two integers, n and m. n is the number of depots on the railroad (1≤n≤1000), and m is the number of attacks Lawrence has resources for (0≤m<n). On the next line will be n integers, each from 1 to 100, indicating the Strategic Value of each depot in order. End of input will be marked by a line with n=0 and m=0, which should not be processed.
 

 

Output
For each data set, output a single integer, indicating the smallest Strategic Value for the railroad that Lawrence can achieve with his attacks. Output each integer in its own line.
 

 

Sample Input
4 1 4 5 1 2 4 2 4 5 1 2 0 0
 

 

Sample Output
17 2
初始化为2的60次方才行,这里错了好多次,还要int64才行,唉这里,好坑!看看题目,明显有dp[i][j]=min(dp[i-1][k]+cos(k,j))
这样,用一个四边形不等式就可以优化了,注意,这里的cost,也可以用dp求出来,因为有很多的共同因子啊,这样才能a了去!
怎么求cost呢?明显cost[i][j]是由cost[i+1][j]+一个第i个因子和(i+1,j)的所有的积的和(记作val[i][j]),那么怎么求val[i][j]呢?
明显val[i][j]是由val[i][j-1]+第i数和第j个数的积!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define MAXN 1005
#define inf  (__int64)1<<60
__int64 prime[MAXN],dp[MAXN][MAXN],kk[MAXN][MAXN],cost[MAXN][MAXN],val[MAXN][MAXN];

int main()
{
    int n,m,i,j,k;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
       if(n==0&&m==0)
       break;
       for(i=1;i<=n;i++)
       {
           scanf("%I64d",&prime[i]);
       }
       memset(cost,0,sizeof(cost));
       memset(val,0,sizeof(val));
       for(i=1;i<n;i++)
          for(j=i+1;j<=n;j++)
          {
              val[i][j]=val[i][j-1]+prime[i]*prime[j];

          }
       for( i=n-1;i>=1;--i)
        {
            for( j=i+1;j<=n;++j)
            {
                cost[i][j]=cost[i+1][j]+val[i][j];
                //printf("cost %d %d\n",cost[i][j],ff(i,j));
            }
        }
       for(i=0;i<=m;i++)
            for(j=0;j<=n;j++)
            {
                dp[i][j]=inf;
            }
       for(i=1;i<n;i++)
       {
           dp[0][i]=cost[1][i];
           kk[0][i]=1;
       }
       for(i=1;i<=m;i++)
       {
           kk[i][n+1]=n-1;
           for(j=n;j>i;j--)
           {
               for(k=kk[i-1][j];k<=kk[i][j+1];k++)
               {
                   int temp=dp[i-1][k]+cost[k+1][j];
                   if(temp<dp[i][j])
                   {
                       dp[i][j]=temp;
                       kk[i][j]=k;
                   }
               }
           }
       }
       printf("%I64d\n",dp[m][n]);
    }
    return 0;
}

posted @   jlins  阅读(314)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
阅读排行:
· 无需6万激活码!GitHub神秘组织3小时极速复刻Manus,手把手教你使用OpenManus搭建本
· C#/.NET/.NET Core优秀项目和框架2025年2月简报
· Manus爆火,是硬核还是营销?
· 终于写完轮子一部分:tcp代理 了,记录一下
· 【杭电多校比赛记录】2025“钉耙编程”中国大学生算法设计春季联赛(1)
点击右上角即可分享
微信分享提示