hdu2660 Accepted Necklace (DFS)

Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
 

 

Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.
 

 

Output
For each case, output the highest possible value of the necklace.
 

 

Sample Input
1 2 1 1 1 1 1 3
 

 

Sample Output
1
 
题目意思:求出K个宝石最大价值总和,但重量不能超过W;
#include<stdio.h>
struct ston
{
    int sa,sw;
};
struct ston s[25],tem;
int su,N,K,W;
void DFS(int i,int suma, int w,int k)
{
    int j;
    if(su<suma)//比较总价值
        su=suma;
    if(k==K)//宝石个数不能超过K个
    return ;
    for(j=i+1;j<=N;j++)
    if(s[j].sw+w<=W&&k+1<=K)
    DFS(j,s[j].sa+suma,s[j].sw+w,k+1);
}
int main()
{
    int t,i,j,e,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&N,&K);
        for(i=1;i<=N;i++)
        scanf("%d%d",&s[i].sa,&s[i].sw);
        scanf("%d",&W);

        for(i=1;i<=N;i++)//先按价值从大到小排序
        {
            e=i;
            for(j=i+1;j<=N;j++)
            if(s[e].sa<s[j].sa)
            e=j;
            tem=s[i];s[i]=s[e];s[e]=tem;
        }
        sum=0;
        for(i=1;i<=N;i++)//看以那个开头总价值最大
        if(s[i].sw<=W&&K>0)
        {
            su=s[i].sa;
            DFS(i,s[i].sa,s[i].sw,1);
            if(su>sum)
            sum=su;
        }
        printf("%d\n",sum);
    }
}


posted @   jlins  阅读(192)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
阅读排行:
· 无需6万激活码!GitHub神秘组织3小时极速复刻Manus,手把手教你使用OpenManus搭建本
· C#/.NET/.NET Core优秀项目和框架2025年2月简报
· Manus爆火,是硬核还是营销?
· 终于写完轮子一部分:tcp代理 了,记录一下
· 【杭电多校比赛记录】2025“钉耙编程”中国大学生算法设计春季联赛(1)
点击右上角即可分享
微信分享提示