UVA 445 - Marvelous Mazes

 Marvelous Mazes

Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z* (asterisk), and spaces.

 

Input and Output

Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that character.

The lowercase letter "b" will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!) or by an end of line.

 

Descriptions for different mazes will be separated by a blank line in both input and output. The input file will be terminated by an end of file.

There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters.

Happy mazing!

 

Sample Input

 

1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T
 
11X21b1X
4X1b1X

 

Sample Output

 

T TTTTT
T  T TT
T T  TT
T   T T
TTT   T
T   T T
TTTTT*T
 
XX   X
XXXX X
题意: 给出一个字符串,由数字、大写字母、*  、和b组成,当s[i]=='b'时,输出换行;当是数字时,如s[i]=2,s[i+1]='T',连续输出两个T;如果出现连续数字,则输出这些连续数字的和个字母,如11A,则输出AA。
#include<stdio.h>
#include<string.h>
int main()
{
    char s[140];
    int i,j,sum,len;
    while(gets(s)!= NULL)
    {
        len=strlen(s);
        sum=0;
        for(i=0;i<len;i++)
        {
            if(s[i]>='0'&&s[i]<='9') /*如果是数字*/
              sum+=s[i]-'0';  /*求输出个数*/
            else
            {   if(s[i]=='!') /*换行*/
                    printf("\n");
                for(j=sum;j>0;j--)
                {
                    if(s[i]=='b') /*输出空格*/
                      printf(" ");
                    else /*输出字母或 * */
                      printf("%c",s[i]);
                }
                sum=0; /*记得输出后清零*/
            }
        }
        printf("\n");
    }
    return 0;
}


 

posted @   jlins  阅读(401)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
阅读排行:
· 无需6万激活码!GitHub神秘组织3小时极速复刻Manus,手把手教你使用OpenManus搭建本
· C#/.NET/.NET Core优秀项目和框架2025年2月简报
· Manus爆火,是硬核还是营销?
· 终于写完轮子一部分:tcp代理 了,记录一下
· 【杭电多校比赛记录】2025“钉耙编程”中国大学生算法设计春季联赛(1)
点击右上角即可分享
微信分享提示