hdu 3342 Legal or Not

Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

 

Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0
 
Sample Output
YES
NO
这题就是拓扑排序的应用。判断该关系是否是有向无环图。
代码如下:
#include<stdio.h>
#include<string.h>
int indegree[101],map[101][101];//indegree[]记录各个节点的入度。
int s[101],top;//栈s[]中存放入度为0的节点。

void tuopu(int n)
{
    int i,j,top=0,t,count=0;
    memset(s,0,sizeof(s));
    for(i=0;i<n;i++)
    {
        if(0==indegree[i])
        {
            s[top++]=i;
        }
    }
    while(top>0)
    {
        t=s[top-1];
        top--;
        count++;
        for(j=0;j<n;j++)
        {
            if(map[t][j])
            {
                indegree[j]--;
                if(0==indegree[j])
                {
                    s[top++]=j;
                }
            }
        }
    }
    if(count<n) printf("NO\n");//count小于n说明存在环
    else printf("YES\n");
}

int main()
{
    int n,m,i,j,a,b;
    while(scanf("%d%d",&n,&m)&&n&&m)
    {
        memset(map,0,sizeof(map));
        memset(indegree,0,sizeof(indegree));
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            if(!map[a][b])
            {
                map[a][b]=1;
                indegree[b]++;
            }
        }
        tuopu(n);
    }
    return 0;
}

 

posted @ 2014-07-17 20:03  段少  阅读(138)  评论(0编辑  收藏  举报