hdu 1312 Red and Black

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

 

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 

 

Sample Output
45
59
6
13
 这题是比较简单的搜素题,可以用广度和深度优先解决。
深搜的代码如下:
#include<stdio.h>
#include<string.h>
const int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
int g[21][21],visited[21][21];
int m,n,count;
bool ok(int a,int b)
{
    if(a>=0&&a<m&&b>=0&b<n)
        return true;
    return false;
}
void dfs(int a,int b)
{
    int i;
    visited[a][b]=1;
    for(i=0;i<4;i++)
    {
        int x=a+dir[i][0];
        int y=b+dir[i][1];
        if(ok(x,y)&&g[x][y]=='.'&&visited[x][y]==0)
        {
            dfs(x,y);
            count++;
        }
    }
}
int main()
{
    int i,j,a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==0&&n==0) break;
        getchar();
        memset(visited,0,sizeof(visited));
        count=1;
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%c",&g[i][j]);
                if(g[i][j]=='@')
                    a=i,b=j;
            }
            getchar();
        }
        dfs(a,b);
        printf("%d\n",count);
    }
    return 0;
}

广度优先搜素代码如下:

#include<stdio.h>
#include<string.h>
const int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
int g[21][21],visited[21][21];
typedef struct{
    int x,y;
}point;
point s[500];
int m,n,top,end;
bool ok(int a,int b)
{
    if(a>=0&&a<m&&b>=0&&b<n)
        return true;
    return false;
}
void bfs(int a,int b)
{
    int i,x,y;
    visited[a][b]=1;
    top=0,end=0;
    s[0].x=a;
    s[0].y=b;
    end++;
    while(top!=end){
    x=s[top].x;
    y=s[top].y;
    top++;
    for(i=0;i<4;i++)
    {
        if(ok(x+dir[i][0],y+dir[i][1])&&visited[x+dir[i][0]][y+dir[i][1]]==0&&g[x+dir[i][0]][y+dir[i][1]]=='.')
        {
            s[end].x=x+dir[i][0];
            s[end].y=y+dir[i][1];
            end++;
            visited[x+dir[i][0]][y+dir[i][1]]=1;
        }
    }
    }
    printf("%d\n",end);
}
int main()
{
    int i,j,a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==0&&n==0) break;
        getchar();
        memset(visited,0,sizeof(visited));
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%c",&g[i][j]);
                if(g[i][j]=='@')
                {
                    a=i;
                    b=j;
                }
            }
            getchar();
        }
        bfs(a,b);
    }
    return 0;
}

 

 

 

 

posted @ 2014-04-15 12:33  段少  阅读(340)  评论(0编辑  收藏  举报