hdu 2053 Switch Game

Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

 

Sample Input
1
5
 

 

Sample Output
1
0
Hint
hint
Consider the second test case:
The initial condition :0 0 0 0 0 …
After the first operation : 1 1 1 1 1 …
After the second operation : 1 0 1 0 1 …
After the third operation : 1 0 0 0 1 …
After the fourth operation : 1 0 0 1 1 …
After the fifth operation : 1 0 0 1 0 …
The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
这题是水题,找出n的约数的个数count,若为偶数则是0,若为奇数则为1;代码如下:
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int n,i,count;
    while(scanf("%d",&n)!=EOF)
    {
        count=0;
        for(i=1;i<=sqrt(n);i++)//求n的约数的个数
        {
            if(n%i==0)
            {
                count+=2;
                if(i==n/i)
                    count--;
            }
        }
        if(count%2==0) printf("0\n");
        else printf("1\n");
    }
    return 0;
}

 

 

 

posted @ 2014-03-15 15:40  段少  阅读(325)  评论(0编辑  收藏  举报