POJ 1365 Prime Land

Problem Description
Everybody in the Prime Land is using a prime base number system. In this system, each positive integer x is represented as follows: Let {pi}i=0,1,2,... denote the increasing sequence of all prime numbers. We know that x > 1 can be represented in only one way in the form of product of powers of prime factors. This implies that there is an integer kx and uniquely determined integers ekx, ekx-1, ..., e1, e0, (ekx > 0), that  The sequence 

(ekx, ekx-1, ... ,e1, e0



is considered to be the representation of x in prime base number system. 

It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division is very simple. 

Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been decided to make an experiment and let a computer to do the operation ``minus one''. 

Help people in the Prime Land and write a corresponding program. 

For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi. 
 

 

Input
The input consists of lines (at least one) each of which except the last contains prime base representation of just one positive integer greater than 2 and less or equal 32767. All numbers in the line are separated by one space. The last line contains number 0.
 

 

Output
The output contains one line for each but the last line of the input. If x is a positive integer contained in a line of the input, the line in the output will contain x - 1 in prime base representation. All numbers in the line are separated by one space. There is no line in the output corresponding to the last ``null'' line of the input.
 

 

Sample Input
17 1
5 1 2 1
509 1 59 1
0
 
Sample Output
2 4
3 2
13 1 11 1 7 1 5 1 3 1 2 1
先离线计算出[2..32767]的素数表,然后进入测试:
对输入的每个素数表示,先将其转化为十进制数表示x;然后再反过来将x-1转化为素数表示。
代码如下:
#include<stdio.h>
#include<math.h>
#include<string.h>
int s[32767],num=1;
bool u[32767];
void preper()
{
    int i,j;
    memset(u,true,sizeof(u));
    for(i=2;i<=32767;i++)
    {
        if(u[i]) s[num++]=i;
        for(j=1;j<num;j++)
        {
            if(i*s[j]>32767) break;
            u[i*s[j]]=false;
            if(i%s[j]==0) break;
        }
    }
}
int main()
{
    int i,a,b,sum=1,count=0;
    char c;
    preper();
    while(1)
    {
        scanf("%d",&a);
        if(a==0) break;
        scanf("%d",&b);
        sum*=floor(pow(a,b)+0.5);
        c=getchar();
        if(c=='\n')
        {
            sum-=1;
            for(i=num-1;i>=1;i--)
            {
                if(sum%s[i]==0)
                {
                    count=0;
                    while(sum%s[i]==0)
                    {
                        count++;
                        sum/=s[i];
                    }
                if(sum!=1)    printf("%d %d ",s[i],count);
                else {printf("%d %d\n",s[i],count); break;}
                }
            }
            sum=1;
        }
    }
    return 0;
}

 

 

 
posted @ 2014-01-21 20:45  段少  阅读(400)  评论(0编辑  收藏  举报