HDU1087Super Jumping! Jumping! Jumping!(dp找和最大)

 

Super Jumping! Jumping! Jumping!
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25632    Accepted Submission(s): 11333
Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
HDU1087Super Jumping! Jumping! Jumping! - 凌晨一点 - 虚灵
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the maximum according to rules, and one line one case.
 
Sample Input

3 1 3 2 4 1 2 3 4 4 3 3 2 1 0

 
Sample Output

4 10 3


 
Author
lcy
 
Recommend
We have carefully selected several similar problems for you:  1159 1069 2084 1203 2602 
 题意:给n个数,每个数表示该点的价值,从第一个点开始,则初始具有第一个点的价值,可以往后随意跳几格,但是要求跳的下一个点的价值要比该点的价值高,否者终止,且跳的过程中不可回头跳。

思路:dp[i],循环判断i点前的点在小于i点的条件下某点直接跳到i点时的价值和最大,即记为dp[i],最后比较最大的dp[i]值。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
int main()
{
    int n,maxs;
    int a[1005];
    int dp[1005];   //记录走到该点时最大收获
    while(~scanf("%d",&n))
    {
        if(n==0)
        break;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            dp[i]=a[i];
        }
         maxs=a[1];
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<i;j++)
            {

                if(a[i]>a[j])
                {
                    dp[i]=max(dp[i],dp[j]+a[i]);//找到从j点跳到i点时价值和最大并存到dp[i]中
                }
            }
            if(dp[i]>maxs)
                    maxs=dp[i];
        }

        printf("%d\n",maxs);
    }
    return 0;
}

 

posted @ 2015-08-22 18:29  Lincy*_*  阅读(164)  评论(0编辑  收藏  举报