HDU1051Wooden Sticks
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4 Accepted Submission(s) : 3
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
2 1 3
Source
Asia 2001, Taejon (South Korea)
题意:
给n根木棍的长度和重量。根据要求求出制作木棍的最短时间。建立第一个木棍需要1分钟,若是接着要制作的木棍重量和长度都比此木棍长就不需要建立的时间,若是没有,则再需要建立时间。求时间最小为多少。
思路:和简单的贪心一样,,无非是排序然后for循环标记记录数据,题目挺简单!!!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
struct node
{
int l;
int w;
};
bool cmp(node a,node b)
{
if(a.l==b.l)
return a.w<b.w;
return a.l<b.l;
}
int main()
{
int t,n,k,l,ll,ans;
node nodes[50005];
int visit[50005];
scanf("%d",&t);
while(t--)
{
k=0;
l=0;
memset(visit,0,sizeof(visit));
//visit[0]=1;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d%d",&nodes[i].l,&nodes[i].w);
}
sort(nodes,nodes+n,cmp);
while(k<n)
{
ll=0;
for(int i=0;i<n;i++)
{
if(visit[i]==0&&ll==0)
{
ll=1;
ans=nodes[i].w;
}
if(visit[i]==0&&nodes[i].w>=ans)
{
ans=nodes[i].w;
k++;
visit[i]=1;
}
}
l++;
}
printf("%d\n",l);
}
return 0;
}