HDU1969Pie (分馅饼)

Pie
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4573    Accepted Submission(s): 1851
Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 
Sample Input

3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2

 
Sample Output

25.1327 3.1416 50.2655


 
Source
NWERC2006
 
Recommend
wangye   |   We have carefully selected several similar problems for you:  1551 2899 2446 2298 2333 
题意:生日分馅饼,有相同高度不同底面半径的N个不同种馅饼要求均分给F个朋友和自己(就是说要分给F+1个人),而求每人得到的馅饼要是一整块;

思路:二分,

注意::1.精度while((right-left)>1e-6)就能过

             2.pi要定意为double pi=acos(-1.0);或者#define pi acos(-1.0)

             3.初学二分double left,right,mid,node;这些数据都要定义为double;

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
#define pi acos(-1.0)
int main()
{
    int m,n,f,a;
    int ri;
    int k,flag;
    double v[10005],node;
    double left,right,mid;
    double sum,max;
    while(~scanf("%d",&m))
    {
    while(m--)
    {
        sum=0;
        scanf("%d%d",&n,&f);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            v[i]=pi*a*a;
            sum=sum+v[i];

        }
        f=f+1;
        max=sum/f;
        left=0,right=max;
        while ((right-left)>1e-6)
      // int g=3;
      // while(g--)
        {
         k=0;
         flag=0;
         mid=(left+right)/2;
        for(int i=0;i<n;i++)
        {
            node=v[i];
            while(node>=mid)
            {
                node=node-mid;
                k++;
                if(k==f)
             {
                flag=1;
                break;
             }
            }
            //printf("!!!!!\n");
            if(flag==1)
            break;
        }
        if(flag==1)
        left=mid;
        else
        right=mid;
        }
        //printf("!!!!!!!!!\n");
        printf("%.4lf\n",mid);
    }
    }
    return 0;
}
 

 

posted @ 2015-08-22 18:07  Lincy*_*  阅读(261)  评论(0编辑  收藏  举报