1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
 

Sample Output:

3 4
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=100005;
vector<int> v[maxn];
int main(){
    int n,m,k;
    int in[maxn]={0};
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;i++){
        int a,b;
        scanf("%d %d",&a,&b);
        v[a].push_back(b);
        in[b]++;
    }
    vector<int> ve;
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        int flag=1;
        vector<int> cnt(in,in+n+1);//将in赋值给cnt,注意这种方法
        vector<int> vt;
        int temp;
        for(int j=0;j<n;j++){
            scanf("%d",&temp);
            if(cnt[temp]!=0){
                flag=0;
            }
            for(int t=0;t<v[temp].size();t++){
                cnt[v[temp][t]]--;
            }
        }
        if(flag==0){
            ve.push_back(i);
        }
    }
    for(int i=0;i<ve.size();i++){
        printf("%d",ve[i]);
        if(i<ve.size()-1){
            printf(" ");
            }
        }
        printf("\n");
    return 0;
}

 

posted @ 2021-03-11 22:01  XA科研  阅读(70)  评论(0编辑  收藏  举报