1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27
 

Sample Output:

14.1.28
 
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=100005;

int main(){
    int a1,b1,c1,a2,b2,c2;
    scanf("%d.%d.%d %d.%d.%d",&a1,&b1,&c1,&a2,&b2,&c2);
    int carry;
    int m1,m2,m3;
    m1=c1+c2;
    carry=m1/29;
    m1=m1%29;
    m2=b1+b2+carry;
    carry=m2/17;
    m2=m2%17;
    m3=a1+a2+carry;
    printf("%d.%d.%d\n",m3,m2,m1);

    return 0;
}

 

posted @ 2021-03-11 17:19  XA科研  阅读(41)  评论(0编辑  收藏  举报