1070 Mooncake (25 分) 贪心

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤), the number of different kinds of mooncakes, and D (≤ thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5
 

Sample Output:

9.45



复制代码
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
struct M{
    double inv;
    double allpri;
    double price;
}m[maxn];
bool cmp(M a,M b){
    return a.price>b.price;
}
int main(){
    int n,dem;
    scanf("%d %d",&n,&dem);
    for(int i=0;i<n;i++){
        scanf("%lf",&m[i].inv);
    }
    for(int i=0;i<n;i++){
        scanf("%lf",&m[i].allpri);
        m[i].price=m[i].allpri/m[i].inv;
    }
    sort(m,m+n,cmp);
    double ans=0;
    for(int i=0;i<n;i++){
        if(m[i].inv<=dem){
            dem-=m[i].inv;
            ans+=m[i].allpri;
        }
        else{
            ans+=(m[i].price*dem);
            dem-=dem;
            break;
        }
    }
    printf("%.2f\n",ans);
    return 0;
}
复制代码

 

posted @   XA科研  阅读(96)  评论(0编辑  收藏  举报
编辑推荐:
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
阅读排行:
· 10年+ .NET Coder 心语 ── 封装的思维:从隐藏、稳定开始理解其本质意义
· 提示词工程——AI应用必不可少的技术
· 地球OL攻略 —— 某应届生求职总结
· 字符编码:从基础到乱码解决
· SpringCloud带你走进微服务的世界
点击右上角即可分享
微信分享提示