1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2 lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
 

Sample Output:

3 4 2 6 5 1


#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
#define  inf  0x3fffffff
stack<int> s;
vector<int> pre;
vector<int> mid;
vector<int> post;
void toPost(int root,int left,int right){//root为先序中根节点的下标,left和right分别为中序中子树的左右边界
    if(left>right){
        return ;
    }
    int i=left;
    while(i<right&&mid[i]!=pre[root]){
        i++;
    }
    toPost(root+1,left,i-1);
    toPost(root+1+i-left,i+1,right);
    post.push_back(pre[root]);
    
}
int main(){
    int n;
    scanf("%d",&n);
    int cnt=0;
    do{
        string ss;
        getline(cin,ss);
        if(ss[1]=='u'){
            ss=ss.substr(5);
            int ds=ss[0]-'0';
            s.push(ds);
            pre.push_back(ds);
        }
        else if(ss[1]=='o'){
            int k=s.top();
            mid.push_back(k);
            s.pop();
            cnt++;
        }
    }while(cnt<n);
    toPost(0,0,n-1);
    for(int i=0;i<n;i++){
        if(i==n-1){
            printf("%d\n",post[i]);
        }
        else{
            printf("%d ",post[i]);
        }
    }
    return 0;
}

第五个测试点过不去,应该是输入的问题,另外,不太理解由先序和中序确定后序的代码逻辑。。。明天好好研究

修改输入方式后,成功AC:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
#define  inf  0x3fffffff
stack<int> s;
vector<int> pre;
vector<int> mid;
vector<int> post;
//post(0,0,n-1);
void toPost(int root,int left,int right){//root为先序中根节点的下标,left和right分别为中序中子树的左右边界
    if(left>right){
        return ;
    }
    int i=left;
    while(i<right&&mid[i]!=pre[root]){
        i++;
    }
    toPost(root+1,left,i-1);//递归结束后,root到达左子树的左边叶子结点
    toPost(root+1+i-left,i+1,right);//递归结束后,root到达右子树的右边叶子结点
    post.push_back(pre[root]);
    
}
//pre(n-1,0,n-1);
//void toPre(int root,int left,int right){
//    if(left>right){
//        return ;
//    }
//    int i=left;
//    while(i<right&&mid[i]==post[root]){
//        i++;
//    }
//    toPre(root+1-right+i,left,i-1);
//    toPre(root-1,i+1,right);
//    pre.push_back(post[root]);
//}
int main(){
    int n;
    scanf("%d",&n);
    int cnt=0;
    for(int i=0;i<2*n;i++){
        string ss;
        cin>>ss;
        if(ss=="Push"){
            int ds;
            cin>>ds;
            s.push(ds);
            pre.push_back(ds);
        }
        else {
            int k=s.top();
            mid.push_back(k);
            s.pop();
        }
    }
    toPost(0,0,n-1);
    for(int i=0;i<n;i++){
        if(i==n-1){
            printf("%d\n",post[i]);
        }
        else{
            printf("%d ",post[i]);
        }
    }
    return 0;
}

 

posted @ 2021-02-23 00:32  XA科研  阅读(56)  评论(0编辑  收藏  举报