1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤), the total number of diamonds on the chain, and M (≤), the amount that the customer has to pay. Then the next line contains N positive numbers D1​​DN​​ (Di​​103​​ for all ,) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj > with (Di + ... + Dj −) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
 

Sample Output 1:

1-5
4-6
7-8
11-11
 

Sample Input 2:

5 13
2 4 5 7 9
 

Sample Output 2:

2-4
4-5

题意:
给出一串序列,求出等于所给值的连续子列,若没有,则求出大于且相差最小的连续子列。
题解:
用minn来存储大于等于所给值的连续子列和的最小值,用一维数组存储起点的终点。

代码一:时间复杂度O(n^2)
#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int dia[maxn],num=0;
int endx[maxn],sum[maxn];//endx用来保存起点的终点
int main(){
    int n,m,a,b;
    fill(endx,endx+maxn,0);
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++){
        scanf("%d",&dia[i]);
    }
    int minn=0x3fffffff;//minn为不小于m的最小值
    for(int i=1;i<=n;i++){
        num=0;
        for(int j=i;j<=n;j++){
            num+=dia[j];
            if(num>=m){
                sum[i]=num;
                endx[i]=j;//起点i的终点为j
                if(num<minn){
                    minn=num;
                }
                break;
            }
        }
    }
    for(int i=1;i<=n;i++){
        if(sum[i]==minn){
            printf("%d-%d\n",i,endx[i]);
        }
    }
    system("pause");//让程序暂停,防止一闪而过
    return 0;
}

有两个测试点超时

代码二:二分法 ,时间复杂度O(nlogn)

 dia数组满足递增,所以可以用二分法查找右边界

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int dia[maxn],dis[maxn];//dis保存右边界
vector<int> vec;
int twofen(int i,int n,int m){
    int left=i+1;
    int right=n;
    int mid;
    while(left<right){
        mid=(left+right)/2;
        if(dia[mid]-dia[i]>=m){
            right=mid;
        }
        else{
            left=mid+1;
        }
    }
    dis[i]=right;//记录右边界
    return dia[right]-dia[i];//返回最接近m的值
}
int main(){
    int n,m;
    scanf("%d %d",&n,&m);
    dia[0]=0;
    for(int i=1;i<=n;i++){
        scanf("%d",&dia[i]);
        dia[i]=dia[i]+dia[i-1];//dia保存到0位置的序列和
    }
    int res;
    int minn=0x3fffffff;
    for(int i=0;i<n;i++){
        res=twofen(i,n,m);
        if(res>=m)
        {
            if(res==minn){
                vec.push_back(i);
            }
            else if(res<minn){
                minn=res;
                vec.clear();
                vec.push_back(i);
            }
        }
        else{
            break;
        }
    }
    for(int i=0;i<vec.size();i++){
        printf("%d-%d\n",vec[i]+1,dis[vec[i]]);
    }
    system("pause");
    return 0;
}

 



posted @ 2021-02-09 23:01  XA科研  阅读(70)  评论(0编辑  收藏  举报