1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
 

Sample Output:

YES
NO
NO
YES
NO

题解:模拟入队出队操作
#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
stack<int> st;
int m,n,k;
int num[maxn];
bool isSeq(){
    while(st.size()>0){//清空前一次栈内元素
        st.pop();
    }
    int k=0;
    for(int i=1;i<=n;i++){
        if(st.size()>=m){
            return false;
        }
        st.push(i);
        while(st.top()==num[k]){
            st.pop();
            k++;
            if(st.size()==0){//一定要判断,否则不能执行st.top()语句
                break;
            }
        }
    }
    if(st.size()>=1){
        return false;
    }
    else{
        return true;
    }
    
}
int main(){
    scanf("%d %d %d",&m,&n,&k);
    for(int i=0;i<k;i++){
        for(int j=0;j<n;j++){
            scanf("%d",&num[j]);
        }
        if(isSeq()){
            printf("YES\n");
        }
        else{
            printf("NO\n");
        }
    }
    return 0;
}

优化代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int m,n,k;
vector<int> v;
bool isSeq(){
    stack<int> st;
    int k=0;
    for(int i=1;i<=n;i++){
        if(st.size()>=m){
            return false;
        }
        st.push(i);
        while(!st.empty()&&st.top()==v[k]){
            st.pop();
            k++;
        }
    }
    if(st.size()>=1){
        return false;
    }
    else{
        return true;
    }
    
}
int main(){
    scanf("%d %d %d",&m,&n,&k);
    v.resize(n+1);
    for(int i=0;i<k;i++){
        v.clear();
        for(int j=0;j<n;j++){
            scanf("%d",&v[j]);//注意:vector<> v 在没有初始化大小时,不能使用该语句赋值,只能使用push_back()
        }
        if(isSeq()){
            printf("YES\n");
        }
        else{
            printf("NO\n");
        }
    }
    return 0;
}

 

 
posted @ 2021-02-07 00:02  XA科研  阅读(37)  评论(0编辑  收藏  举报