1054 The Dominant Color (20 分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 8), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤) and N (≤) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
 

Sample Output:

24
题解:C++中map的应用
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
map<int,int> mp;
int num[maxn][maxn];
int main(){
    int m,n;
    scanf("%d %d",&m,&n);
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            scanf("%d",&num[i][j]);
            mp[num[i][j]]++;
        }
    }
    int avg=n*m/2;
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            if(mp[num[i][j]]>=avg){
                printf("%d\n",num[i][j]);
                return 0;
            }
        }
    }
    return 0;
}

优化代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
map<int,int> mp;
int main(){
    int m,n;
    scanf("%d %d",&m,&n);
    int temp;
    int avg=n*m/2;
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            scanf("%d",&temp);
            mp[temp]++;
            if(mp[temp]>=avg){
                printf("%d\n",temp);
                return 0;
            }
        }
    }
    return 0;
}

 



posted @ 2021-02-06 22:33  XA科研  阅读(72)  评论(0编辑  收藏  举报