1028 List Sorting (25分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
 

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90
 

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
 

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
 

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
 

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题解:
简单的排序问题,注意当两者相等时,按id排序
#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
typedef struct student{
    string id;
    string name;
    int grade;
}stu;
bool cmp1(stu a,stu b){
    return a.id<b.id;
}
bool cmp2(stu a,stu b){
    if(a.name==b.name){
        return a.id<b.id;
    }
    else{
        return a.name<b.name;
    }
    
}
bool cmp3(stu a,stu b){
    if(a.grade==b.grade){
        return a.id<b.id;
    }
    else{
        return a.grade<b.grade;
    }
}
stu stus[maxn];
int main(){
    int n,c;
    scanf("%d %d",&n,&c);
    for(int i=0;i<n;i++){
        cin>>stus[i].id;
        cin>>stus[i].name;
        cin>>stus[i].grade;
    }
    if(c==1){
        sort(stus,stus+n,cmp1);
    }
    if(c==2){
        sort(stus,stus+n,cmp2);
    }
    if(c==3){
        sort(stus,stus+n,cmp3);
    }
    for(int i=0;i<n;i++){
        cout<<stus[i].id<<" "<<stus[i].name<<" "<<stus[i].grade<<endl;
    }
    return 0;
}

 

posted @ 2021-02-01 21:33  XA科研  阅读(56)  评论(0编辑  收藏  举报