cigarettes
题目94
cigarettes
时间限制:3000 ms | 内存限制:65535 KB
难度:2
- 描述
-
Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them
one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?
- 输入
- First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
- 输出
- For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
- 样例输入
-
3 4 3 10 3 100 5
- 样例输出
-
5 14 124
#include<iostream>
using namespace std;
int main(){
int test,m,n,i,k,s;
cin>>test;
while(test--){
int s;
cin>>m>>n;
s=m;
i=m;
while(i>=n){
s=s+i/n; //可换的烟
i=i/n+i%n; //现有的烟蒂
}
cout<<s<<endl;
}
return 0;
}