A+B for Input-Output Practice (VIII)
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
Sample Output
10 15 6
#include<stdio.h>
int main()
{
int test,t=0;
scanf("%d",&test);
while(test--)
{
int s=0,i;
int n,a[1000];
scanf("%d",&n);
for(i=0;i<n;i++)
{
if(i==0)
scanf("%d",&a[i]);
else
scanf(" %d",&a[i]);
s+=a[i];
}
t++;
if(t>1)
printf("\n");
printf("%d\n",s);
}
return 0;
}
注意输入输出的格式