POJ 2662 A Walk Through the Forest

Description

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.

Input

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N <= 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 <= d <= 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.

Output

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647.

Sample Input

5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0

Sample Output

2
4
题意;一个人要从树林一端穿到另一端,起点为1,终点为2,要求: 每次到达新点一定是更加接近终点,问有多少种路径;
思路:记忆化加深搜,开始用dijkstra 求出所有点到终点的最短距离。
优先队列+邻接表
#include<stdio.h>
#include<string.h>
#include<queue>
#define INF 0x1f1f1f
using namespace std;
int head[1002];
struct node
{
    int to,w,next;
}q[3000002];
struct node2
{
    int xu,di;
    bool operator < (node2 t)const
    {
        return t.di<di;
    }
}tt,in;
int tot;
int n,sum;
void add(int s,int t,int wi)
{
    q[tot].to=t;
    q[tot].next=head[s];
    q[tot].w=wi;
    head[s]=tot++;
}
int d[1002];
void dijkstra(int v)
{
    priority_queue<node2>dis;
    int i;
    in.xu=v;
    in.di=0;
    d[v]=0;
    dis.push(in);
    while(!dis.empty())
    {
        tt=dis.top();
        if(tt.xu==1)break;
        dis.pop();
        for(i=head[tt.xu];i;i=q[i].next)
        {
            in.xu=q[i].to;
            in.di=tt.di+q[i].w;
            if(in.di<d[in.xu])
            {
                d[in.xu]=in.di;
                dis.push(in);
            }
        }
        
    }
}
int j[1002];
int dfs(int r)
{
    int i,k=0;
    if(j[r]!=-1)
        return j[r];
    for(i=head[r];i;i=q[i].next)
        if(d[q[i].to]<d[r])
            k+=dfs(q[i].to);
    return j[r]=k;
}
int main()
{
    int i,m,a,b,w;
    while(scanf("%d",&n),n)
    {
        scanf("%d",&m);
        tot=1;
        memset(j,-1,sizeof(j));
        memset(head,0,sizeof(head));
        memset(d,INF,sizeof(d));
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&w);
            add(a,b,w);
            add(b,a,w);
        }
        dijkstra(2);
        j[2]=1;
        printf("%d\n",dfs(1));
    }
    return 0;
}

 

posted @ 2012-04-14 23:09  'wind  阅读(318)  评论(0编辑  收藏  举报