HDU 2710 Max Factor【素数筛选】

Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
Input
* Line 1: A single integer, N
* Lines 2..N+1: The serial numbers to be tested, one per line
Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
Sample Input
4
36
38
40
42
Sample Output
38
View Code
#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
int a[20001];
int i,j,n,p,q,max;
memset(a,0,sizeof(a));
a[1]=1;
for(i=2;i<=20000;i++)
if(!a[i])
{
for(j=i;j<=20000;j+=i)
a[j]=i;
}
while(scanf("%d",&n)!=EOF)
{
q=max=0;
while(n--)
{
scanf("%d",&p);
if(a[p]>max)
{
max=a[p];
q=p;
}
}
printf("%d\n",q);
}
return 0;
}


posted @ 2012-04-06 16:57  'wind  阅读(214)  评论(0编辑  收藏  举报