HDU 1018Big Number 【阶乘位数】

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
2
10
20
Sample Output
7
19
 
总结:利用数学公式(斯特林公式:lnN!=NlnN-N+0.5*ln(2*N*pi))求出位数即可
        #include<stdio.h>
#include<math.h>
#define p 3.14159265
int n,res;
void ws()
{
double t;
t=(n*log(n)-n+0.5*log(2*n*p))/log(10);
res=(int)t+1;
printf("%d\n",res);
}
int main()
{
int k;
scanf("%d",&k);
while(k--)
{
scanf("%d",&n);
ws();
}
return 0;
}


posted @ 2012-04-06 16:56  'wind  阅读(200)  评论(0编辑  收藏  举报