HDU 1028 Ignatius and the Princess III 母函数

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
code:
View Code
#include<stdio.h>
int main()
{
int c1[200],c2[200];
int n,i,j,k;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<=n;++i)
{
c1[i]=1;
c2[i]=0;
}
for(i=2;i<=n;++i)
{
for(j=0;j<=n;++j)
for(k=0;k+j<=n;k+=i)
c2[j+k]+=c1[j];

for(j=0;j<=n;++j)
{
c1[j]=c2[j];
c2[j]=0;
}
}
printf("%d\n",c1[n]);

}

return 0;
}


posted @ 2012-04-06 16:44  'wind  阅读(178)  评论(0编辑  收藏  举报