HDU 4165 Pills

Problem Description
Aunt Lizzie takes half a pill of a certain medicine every day. She starts with a bottle that contains N pills.
On the first day, she removes a random pill, breaks it in two halves, takes one half and puts the other half back into the bottle.
On subsequent days, she removes a random piece (which can be either a whole pill or half a pill) from the bottle. If it is half a pill, she takes it. If it is a whole pill, she takes one half and puts the other half back into the bottle.
In how many ways can she empty the bottle? We represent the sequence of pills removed from the bottle in the course of 2N days as a string, where the i-th character is W if a whole pill was chosen on the i-th day, and H if a half pill was chosen (0 <= i < 2N). How many different valid strings are there that empty the bottle?
Input
The input will contain data for at most 1000 problem instances. For each problem instance there will be one line of input: a positive integer N <= 30, the number of pills initially in the bottle. End of input will be indicated by 0.
Output
For each problem instance, the output will be a single number, displayed at the beginning of a new line. It will be the number of different ways the bottle can be emptied.
Sample Input
6
1
4
2
3
30
0
Sample Output
132
1
14
2
5
3814986502092304
分析:用s[i][j] 表示当前整片药的数量为 i ,残片为 j,   则s[i][j]=s[i-1][j+1]+s[i][j-1]   应为吃残片的时候 残片数量减少,整片的数量不变,吃整片的时候,整片减少而残片增加。
code:
View Code
#include<stdio.h>
#include<string.h>
long long a[31][31];
int main()
{
int i,j,n;
memset(a,0,sizeof(a));
for(i=1;i<=30;i++)
a[0][i]=1;
for(i=1;i<=30;i++)
{
a[i][0]=a[i-1][1];
for(j=1;j<=30-i;j++)
a[i][j]=a[i][j-1]+a[i-1][j+1];
}
while(scanf("%d",&n),n)
{
printf("%lld\n",a[n][0]);
}
return 0;
}

posted @ 2012-03-16 17:02  'wind  阅读(280)  评论(0编辑  收藏  举报