POJ 2255 Tree Recovery【二叉树重建】

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

D
/ \
/ \
B E
/ \ \
/ \ \
A C G
/
/
F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

code:

View Code
#include<stdio.h>
#include<stdlib.h>
struct node
{
int left;
int right;
}tr[100];
int root;
char pr[100];
char mi[100];
void init(int p)
{
tr[p].left=-1;
tr[p].right=-1;
}
void fason(int pa,int son)
{
if(son<pa)
if(tr[pa].left==-1)
{
init(son);
tr[pa].left=son;
}
else fason(tr[pa].left,son);
else
{
if(tr[pa].right==-1)
{
init(son);
tr[pa].right=son;
}
else fason(tr[pa].right,son);
}
}
void build_tree()
{
int i,j;
for(i=0;mi[i];i++)
if(mi[i]==pr[0])
{
root=i;
init(root);
break;
}
for(i=1;pr[i];i++)
for(j=0;mi[j];j++)
{
if(mi[j]==pr[i])
{
fason(root,j);
break;
}
}
}
void back_out(int p)
{
if(tr[p].left!=-1) back_out(tr[p].left);
if(tr[p].right!=-1)back_out(tr[p].right);
printf("%c",mi[p]);
}
int main()
{
while(scanf("%s%s",pr,mi)!=EOF)
{
build_tree();
back_out(root);
printf("\n");
}
return 0;
}


posted @ 2012-03-16 12:49  'wind  阅读(175)  评论(0编辑  收藏  举报