栈的应用(平衡括号)

Description

There are six kinds of brackets: ‘(‘, ‘)’, ‘[‘, ‘]’, ‘{’, ‘}’. dccmx’s girl friend is now learning java programminglanguage, and got mad with brackets! Now give you a string of brackets. Is it valid? For example: “(([{}]))” is valid, but([)]” is not.

Input

 First line contains an integer T (T<=10): the number of test case.

Next T lines, each contains a string: the input expression consists of brackets.

The length of a string is between 1 and 100.

Output

For each test case, output “Valid” in one line if the expression is valid, or “Invalid” if not.

Sample Input

 

2
{{[[(())]]}}
({[}])

Sample Output 

Valid
Invalid

代码:

View Code
  #include<stdio.h>
#include<string.h>
int main()
{
char stack(char a[],int n);
int n,i,len,j;
char a[100];
scanf("%d%*c",&n);
for(i=0;i<n;i++)
{
scanf("%s",a);
len=strlen(a);
if(stack(a,len))
printf("Valid\n");
else
printf("Invalid\n");
}
return 0;
}
char stack(char a[],int n)
{
int i;
char b[100],t;
int top=0,buttom=0;
for(i=0;i<n;i++)
{
if(a[i]=='(' || a[i]=='[' || a[i]=='{')
b[top++]=a[i];
else
{
if(top==0)
{top=1;
break;}
t=b[top-1];
if((t=='['&&a[i]==']')||(t=='{'&&a[i]=='}')||(t=='('&&a[i]==')'))
{ --top; t=b[top-1]; }
}
}
if(top==buttom)
return 1;
else return 0;

}


posted @ 2012-03-16 12:45  'wind  阅读(204)  评论(0编辑  收藏  举报