POJ 2965 The Pilots Brothers' refrigerator【枚举】

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location[i, j](1 ≤ i, j ≤ 4). However, this also changes states of all handles in rowiand all handles in columnj.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

分析:

在看了该题的讨论版后,得知一个高效的解法,总结如下:先看一个简单的问题,如何把'+'变成'-'而不改变其他位置上的状态?答案是将该位置(i,j)及位置所在的行(i)和列(j)上所有的handle更新一次,结果该位置被更新了7次,相应行(i)和列(j)的handle被更新了6次,剩下的被更新了4次.被更新偶数次的handle不会造成最终状态的改变.因此得出高效解法,在每次输入碰到'+'的时候,自增该位置与相应的行和列,当输入结束后,遍历数组,所有为奇数的位置则是操作的位置,而奇数位置的个数之和则是最终的操作次数.

code:

View Code
#include<stdio.h>
#include<string.h>
int main()
{
char s[5];
int state[5][5];
int i,j,k,tot;
memset(state,0,sizeof(state));
tot=0;
for(i=0;i<4;i++)
{
scanf("%s",s);
for(j=0;j<4;j++)
if(s[j]=='+')
{
state[i+1][j+1]=!state[i+1][j+1];
for(k=1;k<=4;k++)
{
state[i+1][k]=!state[i+1][k];
state[k][j+1]=!state[k][j+1];
}
}
}
for(i=1;i<=4;i++)
for(j=1;j<=4;j++)
if(state[i][j])
tot++;
printf("%d\n",tot);
for(i=1;i<=4;i++)
for(j=1;j<=4;j++)
if(state[i][j])
printf("%d %d\n",i,j);
return 0;
}


posted @ 2012-03-16 12:35  'wind  阅读(171)  评论(0编辑  收藏  举报