HLG 1018 Cow Contest【floyd 传递闭包】

Description

N(1 ≤N≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cowAhas a greater skill level than cowB(1 ≤AN; 1 ≤BN;AB), then cowAwill always beat cowB.

Farmer John is trying to rank the cows by skill level. Given a list the results ofM(1 ≤M≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

For each test case:

* Line 1: Two space-separated integers:NandM
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer,A, is the winner) of a single round of competition:AandB

Process to the end of file.

Output

For each test case:

* Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2
code:
View Code
#include<stdio.h>
#include<string.h>
const intmaxnum=102;
intmain()
{
inti,p,q,j;
intd[maxnum][maxnum];
intn,m,sum,k,tot;
while(scanf("%d%d",&n,&m)!=EOF)
{
sum=0;
memset(d,0,sizeof(d));
for(i=1;i<=m;i++)
{
scanf("%d%d",&p,&q);
d[p][q]=1;
}
for(k=1;k<=n;k++)
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
d[i][j]=d[i][j]||(d[i][k]&&d[k][j]); //传递闭包
for(i=1;i<=n;i++)
{
tot=0;
for(j=1;j<=n;j++)
if(d[i][j]||d[j][i])
tot++;
if(tot==n-1)
sum++;
}
printf("%d\n",sum);
}
return0;
}

posted @ 2012-03-15 23:29  'wind  阅读(270)  评论(0编辑  收藏  举报