HDU 1240 Asteroids!【广搜】

Problem Description
You're in space.                  
You want to get home.             
There are asteroids.              
You don't want to hit them.       
Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be   formatted according to the following description, and there will be no blank lines separating data sets.  
A single data set has 5 components:                                                                       
Start line - A single line, "START N", where 1 <= N <= 10.                                                 
Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice           through the asteroid field. Each position in the matrix will be one of two                                 values:                                                                                                    
'O' - (the letter "oh") Empty space                                                                       
'X' - (upper-case) Asteroid present                                                                       
Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting      position. The coordinate values will be integers separated by individual spaces.                          
Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The  coordinate values will be integers separated by individual spaces.                                         
End line - A single line, "END"                                                                           
The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will   be an integer between 0 and N-1, inclusive.                                                               
The first coordinate in a set indicates the column. Left column = 0.                                      
The second coordinate in a set indicates the row. Top row = 0.                                            
The third coordinate in a set indicates the slice. First slice = 0.                                        
Both the Starting Position and the Target Position will be in empty space.                                
Output
For each data set, there will be exactly one output set, and there will be no blank lines separating       output sets.                                                                                               
A single output set consists of a single line. If a route exists, the line will be in the format "X Y",    where X is the same as N from the corresponding input data set and Y is the least number of moves          necessary to get your ship from the starting position to the target position. If there is no route from    the starting position to the target position, the line will be "NO ROUTE" instead.、                      
A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more  precisely, a move will either increment or decrement a single component of your current position vector by 1.                                                                                                        
Sample Input
START 1
O      
0 0 0  
0 0 0  
END    
START 3
XXX    
XXX    
XXX    
OOO    
OOO    
OOO    
XXX    
XXX    
XXX    
0 0 1  
2 2 1  
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END
Sample Output
1 0
3 4
NO ROUTE
分析:三维广搜题,和二维一样思路
 code ①:
View Code
#include<stdio.h>
#include<string.h>
int f[18]={0,0,1,-1,0,0, 0,0,0,0,1,-1, 1,-1,0,0,0,0};
struct node
{
int x;
int y;
int z;
}q[1001];
int main()
{
char a[10];
char s[11][11][11];
int st[11][11][11];
int front,rear,xx,yy,zz,x0,y0,z0,n,i,j,sx,sy,sz,ex,ey,ez,p;
while(scanf("%s%d",a,&n)!=EOF)
{
memset(st,0,sizeof(st));
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%s",s[i][j]);
scanf("%d%d%d",&sx,&sy,&sz);
scanf("%d%d%d",&ex,&ey,&ez);
scanf("%s",a);
front=rear=0;
s[sx][sy][sz]='X';
s[ex][ey][ez]='O';
q[rear].x=sx;
q[rear].y=sy;
q[rear++].z=sz;
while(front<=rear)
{
x0=q[front].x;
y0=q[front].y;
z0=q[front].z;
for(p=0;p<6;p++)
{
xx=x0+f[p];
yy=y0+f[p+6];
zz=z0+f[p+12];
if(s[xx][yy][zz]!='X'&&xx>=0&&xx<n&&yy>=0&&yy<n&&zz>=0&&zz<n)
{
s[xx][yy][zz]='X';
st[xx][yy][zz]=st[x0][y0][z0]+1;
q[rear].x=xx;
q[rear].y=yy;
q[rear++].z=zz;
if(xx==ex&&yy==ey&&zz==ez)
goto loop;
}
}
front++;
}
loop: if((n==1&&s[0][0][0]=='O')||st[ex][ey][ez])
printf("%d %d\n",n,st[ex][ey][ez]);
else printf("NO ROUTE\n");
}
return 0;
}

posted @ 2012-03-15 12:56  'wind  阅读(214)  评论(0编辑  收藏  举报