二分算法的应用——最大化最小值 POJ2456 Aggressive cows

Aggressive cows
Time Limit: 1000MS         Memory Limit: 65536K
Total Submissions: 17797         Accepted: 8485
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output

* Line 1: One integer: the largest minimum distance
Sample Input

5 3
1
2
8
4
9
Sample Output

3

来源:http://poj.org/problem?id=2456

题意:N个牛舍,第i号牛舍在 xi 的位置。其中 M头牛,对位置不满意,所以,要最大化最近的两头牛的距离。

可以把他看成二分的题目,如之前的写的博客,这种问题关键是 编写 二分的条件bool C(x)。这里的条件C(d):可以安排M只牛的位置,使得最近两只牛的距离不小于d。

#include <iostream>
#include <algorithm> 
#include <cstdlib>
#include <cstdio>
#include <cstdlib>
using namespace std;

/*
5
3
1 2 8 4 9
*/
const int maxn = 100000 + 50;
int N, M;
int x[maxn];
int INF;

void input()
{
    cin >> N >> M;
    for (int i = 0; i < N; i++) {
        cin >> x[i];
        INF = max(INF, x[i]);
    }
    INF++;
}

//判断是否满足条件 
bool C(int d)
{
    int last = 0;
    for (int i = 1; i < M; i++) 
    {
        int next = last + 1;
        while (next < N && x[next] - x[last] < d) {
            next++;
        }
        if (next == N) return false;
        last = next;                //遇到间距大于d的,则更新 last,向后继续寻找 
    }
    return true;
}

void solve()
{
    input();
    
    //最开始对x数组进行排序
    sort(x, x + N); 
    
    //初始化解的范围
    int lh = 0, rh = INF;
    
    int mid = 0;
    while (rh - lh > 1)
    {
        mid = (lh + rh) / 2;
        if (C(mid)) {
            lh = mid;
        }
        else {
            rh = mid;
        }
    }
    cout << lh << endl;    
}

int main()
{
    solve();
    return 0;
}

 

 

 

 

 

 

posted @ 2018-02-23 23:04  douzujun  阅读(233)  评论(0编辑  收藏  举报