优先队列:POJ No 3614 Sunscreen 贪心
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 6410 | Accepted: 2239 |
Description
To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........
The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.
What is the maximum number of cows that can protect themselves while tanning given the available lotions?
Input
* Line 1: Two space-separated integers: C and L
* Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi
* Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri
Output
A single line with an integer that is the maximum number of cows that can be protected while tanning
Sample Input
3 2
3 10
2 5
1 5
6 2
4 1
Sample Output
2
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#include <functional>
#include <utility>
using namespace std;
/*
3 2 // C只牛 L个防晒霜
C 行
3 10 minSPF, maxSPF
2 5
1 5
L行
6 2 每种数量, 固定的阳光强度
4 1
*/
const int maxn = 100000;
int C, L; // C只奶牛 , L
typedef pair<int, int> P; // minSPF, maxSPF
//小值先出
priority_queue<int, vector<int>, greater<int> > q;
P cow[maxn], bot[maxn]; //牛(min,max) 和 防晒霜(固定的阳光数, 数量)
void solve();
void input();
void input()
{
scanf("%d%d", &C, &L);
for (int i = 0; i < C; i++) {
scanf("%d%d", &cow[i].first, &cow[i].second);
}
for (int i = 0; i < L; i++) {
scanf("%d%d", &bot[i].first, &bot[i].second);
}
}
void solve()
{
input();
sort(cow, cow + C); //按照最小值阳光强度升序
sort(bot, bot + L); //(first)按照能固定的阳光强度升序
int j = 0, ans = 0;
//当 L 个 防晒霜
for (int i = 0; i < L; i++)
{
//将最小值阳光 和 固定的阳光强度 比较
while (j < C && cow[j].first <= bot[i].first) {
q.push(cow[j].second); //添加到优先队列 (最小值阳光)
j++;
}
//如果 最小值阳光 序列不空,当前 防晒霜未用完
while (!q.empty() && bot[i].second) {
int x = q.top(); q.pop();
// 最小值 小于 能固定的阳光, 方案不存在
if (x < bot[i].first) continue;
//否则,
ans++;
//当前防晒霜--
bot[i].second--;
}
}
printf("%d\n", ans);
}
int main()
{
solve();
return 0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
· 理解Rust引用及其生命周期标识(上)
· 浏览器原生「磁吸」效果!Anchor Positioning 锚点定位神器解析
· DeepSeek 开源周回顾「GitHub 热点速览」
· 物流快递公司核心技术能力-地址解析分单基础技术分享
· .NET 10首个预览版发布:重大改进与新特性概览!
· AI与.NET技术实操系列(二):开始使用ML.NET
· 单线程的Redis速度为什么快?