uva568 - Just the Facts

题目大意: 求N! 的最后一位非零数

注意根据题目在过程中要保留5位,如果利用数组可以节省数据组之间的时间。

 Just the Facts 

The expression N!, read as ``N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,

N N!
0 1
1 1
2 2
3 6
4 24
5 120
10 3628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ($0 \le N \le 10000$). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the valueN, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain `` -> " (space hyphen greater space). Column 10 must contain the single last non-zero digit of N!.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8




#include <iostream>
#include <iomanip>
#include <cstdio>
using namespace std;


int main()
{
    int N;

    while(scanf("%d",&N)!=EOF)
    {
        int ans=1;
        for(int i=1;i<=N;i++)
        {
            ans*=i;
            while (ans%10==0 )
                ans/=10;
            ans=ans%100000;
        }
        printf("%5d -> %d\n",N,ans%10);
    }

    return 0;
}

 

posted @ 2013-10-21 23:03  doubleshik  阅读(164)  评论(0编辑  收藏  举报